1. 03 Sep, 2022 1 commit
  2. 30 May, 2022 4 commits
    • Zéfling's avatar
      Update version · 1525d71b
      Zéfling authored
      - with Ivy partial compilation mode
      - use prettier
      1525d71b
    • Zéfling's avatar
      ng update @angular/cli@13 @angular/core@13 · 44351bd3
      Zéfling authored
      The installed Angular CLI version is outdated.
      Installing a temporary Angular CLI versioned 13.3.7 to perform the update.
       Package successfully installed.
      Using package manager: 'npm'
      Collecting installed dependencies...
      Found 32 dependencies.
      Fetching dependency metadata from registry...
          Updating package.json with dependency @angular-devkit/build-angular @ "13.3.7" (was "12.2.17")...
          Updating package.json with dependency @angular/cli @ "13.3.7" (was "12.2.17")...
          Updating package.json with dependency @angular/compiler-cli @ "13.3.10" (was "12.2.16")...
          Updating package.json with dependency @angular/language-service @ "13.3.10" (was "12.2.16")...
          Updating package.json with dependency ng-packagr @ "13.3.1" (was "12.2.7")...
          Updating package.json with dependency typescript @ "4.6.4" (was "4.3.5")...
          Updating package.json with dependency @angular/animations @ "13.3.10" (was "12.2.16")...
          Updating package.json with dependency @angular/common @ "13.3.10" (was "12.2.16")...
          Updating package.json with dependency @angular/compiler @ "13.3.10" (was "12.2.16")...
          Updating package.json with dependency @angular/core @ "13.3.10" (was "12.2.16")...
          Updating package.json with dependency @angular/forms @ "13.3.10" (was "12.2.16")...
          Updating package.json with dependency @angular/platform-browser @ "13.3.10" (was "12.2.16")...
          Updating package.json with dependency @angular/platform-browser-dynamic @ "13.3.10" (was "12.2.16")...
          Updating package.json with dependency @angular/router @ "13.3.10" (was "12.2.16")...
        UPDATE package.json (1630 bytes)
       Packages successfully installed.
      ** Executing migrations of package '@angular/cli' **
      
      ▸ Remove polyfills required only for Internet Explorer which is no longer supported.
        UPDATE src/polyfills.ts (2340 bytes)
        Migration completed.
      
      ▸ Remove no longer valid Angular schematic options from `angular.json`.
        Migration completed.
      
      ▸ Remove deprecated options from 'angular.json' that are no longer present in v13.
        UPDATE angular.json (4634 bytes)
        Migration completed.
      
      ▸ Updating '.gitignore' to include '.angular/cache'.
        UPDATE .gitignore (519 bytes)
        Migration completed.
      
      ▸ Update library projects to be published in partial mode and removed deprecated options from ng-packagr configuration.
        UPDATE projects/coloration/tsconfig.lib.prod.json (162 bytes)
        Migration completed.
      
      ** Executing migrations of package '@angular/core' **
      
      ▸ Migrates `[routerLink]=""` in templates to `[routerLink]="[]"` because these links are likely intended to route to the current page with updated fragment/query params.
        Migration completed.
      
      ▸ In Angular version 13, the `teardown` flag in `TestBed` will be enabled by default.
        This migration automatically opts out existing apps from the new teardown behavior.
        UPDATE src/test.ts (679 bytes)
        UPDATE projects/coloration/src/test.ts (727 bytes)
        Migration completed.
      
      ▸ As of Angular version 13, `entryComponents` are no longer necessary.
        Migration completed.
      44351bd3
    • Zéfling's avatar
      ng update @angular/cli@12 @angular/core@12 · 076693c2
      Zéfling authored
      The installed Angular CLI version is outdated.
      Installing a temporary Angular CLI versioned 12.2.17 to perform the update.
       Package successfully installed.
      Using package manager: 'npm'
      Collecting installed dependencies...
      Found 32 dependencies.
      Fetching dependency metadata from registry...
          Updating package.json with dependency @angular-devkit/build-angular @ "12.2.17" (was "0.1102.19")...
          Updating package.json with dependency @angular/cli @ "12.2.17" (was "11.2.19")...
          Updating package.json with dependency @angular/compiler-cli @ "12.2.16" (was "11.2.14")...
          Updating package.json with dependency @angular/language-service @ "12.2.16" (was "11.2.14")...
          Updating package.json with dependency ng-packagr @ "12.2.7" (was "11.2.4")...
          Updating package.json with dependency typescript @ "4.3.5" (was "4.1.6")...
          Updating package.json with dependency @angular/animations @ "12.2.16" (was "11.2.14")...
          Updating package.json with dependency @angular/common @ "12.2.16" (was "11.2.14")...
          Updating package.json with dependency @angular/compiler @ "12.2.16" (was "11.2.14")...
          Updating package.json with dependency @angular/core @ "12.2.16" (was "11.2.14")...
          Updating package.json with dependency @angular/forms @ "12.2.16" (was "11.2.14")...
          Updating package.json with dependency @angular/platform-browser @ "12.2.16" (was "11.2.14")...
          Updating package.json with dependency @angular/platform-browser-dynamic @ "12.2.16" (was "11.2.14")...
          Updating package.json with dependency @angular/router @ "12.2.16" (was "11.2.14")...
          Updating package.json with dependency tslib @ "2.4.0" (was "2.0.1")...
          Updating package.json with dependency zone.js @ "0.11.5" (was "0.10.3")...
        UPDATE package.json (1612 bytes)
       Packages successfully installed.
      ** Executing migrations of package '@angular/cli' **
      
      ▸ Remove deprecated options from 'angular.json' that are no longer present in v12.
        UPDATE angular.json (5550 bytes)
        Migration completed.
      
      ▸ Update 'zone.js' to version 0.11.x.
        Read more about this here: https://github.com/angular/angular/blob/master/packages/zone.js/CHANGELOG.md#breaking-changes-since-zonejs-v0111
        UPDATE package.json (1613 bytes)
        UPDATE projects/coloration/src/test.ts (680 bytes)
        UPDATE src/polyfills.ts (2825 bytes)
        UPDATE src/test.ts (632 bytes)
        UPDATE src/environments/environment.ts (665 bytes)
       Packages installed successfully.
        Migration completed.
      
      ▸ Remove 'emitDecoratorMetadata' TypeScript compiler option.
        Decorator metadata is no longer needed by Angular.
        Read more about this here: https://www.typescriptlang.org/docs/handbook/decorators.html#metadata
        UPDATE tsconfig.json (573 bytes)
        UPDATE projects/coloration/tsconfig.lib.json (679 bytes)
        Migration completed.
      
      ▸ Lazy loading syntax migration.
        Update lazy loading string syntax to use dynamic imports.
        Migration completed.
      
      ▸ Remove deprecated ViewEngine-based i18n build and extract options.
        Options present in the configuration will be converted to use non-deprecated options.
        Migration completed.
      
      ▸ Updates Web Worker consumer usage to use the new syntax supported directly by Webpack 5.
        Migration completed.
      
      ▸ Remove invalid 'skipTests' option in '@schematics/angular:module' Angular schematic options.
        Migration completed.
      
      ▸ Replace the deprecated '--prod' in package.json scripts.
        UPDATE package.json (1633 bytes)
        Migration completed.
      
      ** Executing migrations of package '@angular/core' **
      
      ▸ In Angular version 12, the type of ActivatedRouteSnapshot.fragment is nullable.
        This migration automatically adds non-null assertions to it.
        Migration completed.
      
      ▸ `XhrFactory` has been moved from `@angular/common/http` to `@angular/common`.
        Migration completed.
      
      ▸ Automatically migrates shadow-piercing selector from `/deep/` to the recommended alternative `::ng-deep`.
        Migration completed.
      076693c2
    • Zéfling's avatar
      ng update @angular/cli@11 @angular/core@11 · d03d1b86
      Zéfling authored
      Your global Angular CLI version (13.1.4) is greater than your local version (10.0.7). The local Angular CLI version is used.
      
      To disable this warning use "ng config -g cli.warnings.versionMismatch false".
      The installed local Angular CLI version is older than the latest stable version.
      Installing a temporary version to perform the update.
      Installing packages for tooling via npm.
      Installed packages for tooling via npm.
      Using package manager: 'npm'
      Collecting installed dependencies...
      Found 33 dependencies.
      Fetching dependency metadata from registry...
          Updating package.json with dependency @angular-devkit/build-angular @ "0.1102.19" (was "0.1000.7")...
          Updating package.json with dependency @angular/cli @ "11.2.19" (was "10.0.7")...
          Updating package.json with dependency @angular/compiler-cli @ "11.2.14" (was "10.0.11")...
          Updating package.json with dependency @angular/language-service @ "11.2.14" (was "10.0.11")...
          Updating package.json with dependency karma @ "6.3.20" (was "5.0.9")...
          Updating package.json with dependency ng-packagr @ "11.2.4" (was "10.0.4")...
          Updating package.json with dependency typescript @ "4.1.6" (was "3.9.7")...
          Updating package.json with dependency @angular/animations @ "11.2.14" (was "10.0.11")...
          Updating package.json with dependency @angular/common @ "11.2.14" (was "10.0.11")...
          Updating package.json with dependency @angular/compiler @ "11.2.14" (was "10.0.11")...
          Updating package.json with dependency @angular/core @ "11.2.14" (was "10.0.11")...
          Updating package.json with dependency @angular/forms @ "11.2.14" (was "10.0.11")...
          Updating package.json with dependency @angular/platform-browser @ "11.2.14" (was "10.0.11")...
          Updating package.json with dependency @angular/platform-browser-dynamic @ "11.2.14" (was "10.0.11")...
          Updating package.json with dependency @angular/router @ "11.2.14" (was "10.0.11")...
        UPDATE package.json (1667 bytes)
       Packages successfully installed.
      ** Executing migrations of package '@angular/cli' **
      
      ▸ Removing "Solution Style" TypeScript configuration file support.
        DELETE tsconfig.base.json
        UPDATE tsconfig.json (608 bytes)
        UPDATE e2e/tsconfig.e2e.json (213 bytes)
        UPDATE projects/coloration/tsconfig.lib.json (686 bytes)
        UPDATE projects/coloration/tsconfig.spec.json (246 bytes)
        UPDATE src/tsconfig.app.json (204 bytes)
        UPDATE src/tsconfig.spec.json (256 bytes)
        Migration completed.
      
      ▸ Replace deprecated library builder '@angular-devkit/build-ng-packagr'.
        UPDATE angular.json (5391 bytes)
        UPDATE package.json (1615 bytes)
        Migration completed.
      
      ▸ Add 'declarationMap' compiler options for non production library builds.
        UPDATE projects/coloration/tsconfig.lib.prod.json (152 bytes)
        UPDATE projects/coloration/tsconfig.lib.json (714 bytes)
        Migration completed.
      
      ▸ Remove deprecated options from 'angular.json' that are no longer present in v11.
        UPDATE angular.json (5357 bytes)
        Migration completed.
      
      ▸ Update workspace dependencies to match a new v11 project.
        UPDATE package.json (1615 bytes)
       Packages installed successfully.
        Migration completed.
      
      An unhandled exception occurred: Cannot find module '@angular-devkit/core'
      Require stack:
      - /home/zefling/Documents/Git/coloration-demo/node_modules/@angular/core/schematics/utils/project_tsconfig_paths.js
      - /home/zefling/Documents/Git/coloration-demo/node_modules/@angular/core/schematics/migrations/missing-injectable/index.js
      See "/tmp/ng-aui2i1/angular-errors.log" for further details.
      d03d1b86
  3. 02 Jun, 2021 1 commit
  4. 22 Aug, 2020 2 commits
  5. 17 May, 2020 1 commit
  6. 03 May, 2020 2 commits
  7. 02 May, 2020 6 commits
  8. 01 May, 2020 5 commits
  9. 30 Apr, 2020 1 commit
    • Zéfling's avatar
      Add alpha supports · 2279d49d
      Zéfling authored
      - fix float value for rgb
      - fix blue additional
      - Fix demo
      2279d49d
  10. 23 Jan, 2019 1 commit
  11. 22 Jan, 2019 6 commits
  12. 21 Jan, 2019 2 commits
  13. 20 Jan, 2019 6 commits
  14. 19 Jan, 2019 2 commits